Subclipse/Subversion error on Ubuntu: Failed to load JavaHL Library

SVN error on Eclipse/Ubuntu: Failed to load JavaHL Library

Blog about cooking, technology and something else

I’ve installed subclipse and when I restart eclipse and try to share a project, I get this error:

The error is:

In most of the cases is due to the lack of the libsvn-java library, so just install it:

Now you have to tell eclipse where to find this libraries. First, locate where the is:

Now, edit PATH_TO_ECLIPSE/eclipse.ini and add this line below -vmargs:

This is my full eclipse.ini with the line already added:

If you still get the error, you’d probably modified the wrong eclipse.ini. In my case, I have a copy of eclipse decompressed in /app folder, but I also have eclipse.ini in /etc, /usr/lib/eclipse and /opt/ibm/lotus/notes/framework/rcp/eclipse/plugins/com.ibm.rcp.base_6.2.2.20100729-1241/linux/x86/. So, be sure to modify the correct eclipse.ini.

To check if you have modified the correct eclipse.ini, you can follow the Linux troubleshooting section at http://subclipse.tigris.org/wiki/JavaHL.

Ver o post original

Anúncios

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s